Netsetup115 access is denied after uninstalling

Got a question or comment about PowerChurch that doesn't belong anywhere else? Why not post it here!?

Netsetup115 access is denied after uninstalling

Postby AndyMBC » Wed Sep 12, 2018 8:55 pm

I've got a successful installation on our server, 1 computer is able to connect fine, and has consistently worked. Another user is setup for remote access, this worked for a while but an update to PC broke everything. This particular user ended up fed up and purchased a new computer to use with PC at home. It set up our VPN and installed PC without issue. I noticed a maintenance release was pending.

Today I brought the machine to our building to install the maintenance release on the server and allow the bookkeepers machine to update itself (this is the machine that's always been working). I re-indexed the files to prove that the install was good and working.

However it kept erroring on the new machine. Frustrated I uninstalled PC from control panel, and created more issues. Now when I try to install from netsetup again all I get is "Access Is Denied.". I've deleted all the files from programdata.

New machine is Windows 7, All permissions are correct and I'm using the same SMB account as the working computer. Issue happens wired or wireless, VPN or local. I've disabled antivirus just to make sure.

Is there something I'm missing?
AndyMBC
 
Posts: 9
Joined: Wed Sep 12, 2018 8:43 pm

Re: Netsetup115 access is denied after uninstalling

Postby NeilZ » Wed Sep 12, 2018 8:58 pm

AndyMBC wrote:I've got a successful installation on our server, 1 computer is able to connect fine, and has consistently worked. Another user is setup for remote access, this worked for a while but an update to PC broke everything. This particular user ended up fed up and purchased a new computer to use with PC at home. It set up our VPN and installed PC without issue. I noticed a maintenance release was pending.

Today I brought the machine to our building to install the maintenance release on the server and allow the bookkeepers machine to update itself (this is the machine that's always been working). I re-indexed the files to prove that the install was good and working.

However it kept erroring on the new machine. Frustrated I uninstalled PC from control panel, and created more issues. Now when I try to install from netsetup again all I get is "Access Is Denied.". I've deleted all the files from programdata.

New machine is Windows 7, All permissions are correct and I'm using the same SMB account as the working computer. Issue happens wired or wireless, VPN or local. I've disabled antivirus just to make sure.

Is there something I'm missing?


This 'new machine' is the one that is used at home? Did you turn off any firewall running on the 'new' machine when you tried to run the netsetup115.exe ??

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8905
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA

Re: Netsetup115 access is denied after uninstalling

Postby AndyMBC » Wed Sep 12, 2018 9:07 pm

NeilZ wrote:This 'new machine' is the one that is used at home? Did you turn off any firewall running on the 'new' machine when you tried to run the netsetup115.exe ??


Yes it installed fine the first time, and now won't install again.

I just tried this now with no difference.

Just for haha's I made a new admin account on this machine, and it also gives the error.
AndyMBC
 
Posts: 9
Joined: Wed Sep 12, 2018 8:43 pm

Re: Netsetup115 access is denied after uninstalling

Postby NeilZ » Thu Sep 13, 2018 8:40 am

AndyMBC wrote:
NeilZ wrote:This 'new machine' is the one that is used at home? Did you turn off any firewall running on the 'new' machine when you tried to run the netsetup115.exe ??


Yes it installed fine the first time, and now won't install again.

I just tried this now with no difference.

Just for haha's I made a new admin account on this machine, and it also gives the error.


This is definitely a Windows sharing issue, and not a Powerchurch one.
I suggest the following;

1. Make sure that the laptop views the church network as 'Private', not public.
2. Make sure that the WIndows advanced sharing options on the laptop has the settings set to turn on network discovery, file & printer sharing for the Private networks (I do the public too, and turn it off when I'm not on a private network), and for ALL networks, turn ON sharing for accessing files, set to use 128bit encryption, and turn OFF password protected sharing.
3. Insure that the Powerchurch shared drive from the 'server' has full read & write permissions to everyone.

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8905
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA

Re: Netsetup115 access is denied after uninstalling

Postby NeilZ » Thu Sep 13, 2018 9:12 am

Quick question ... you said this machine uses a VPN to access the local network, and I'm guessing that it uses the SHARED drive through that VPN, right?

If that's the case, the laptop will be updated with the MR the next time the user logged in to the VPN to access the server. There was no need to bring the machine to the church.

If that didn't happen, then there's another issue that you may need to look at.

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8905
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA

Re: Netsetup115 access is denied after uninstalling

Postby AndyMBC » Thu Sep 13, 2018 10:08 am

NeilZ wrote:This is definitely a Windows sharing issue, and not a Powerchurch one.
I suggest the following;

1. Make sure that the laptop views the church network as 'Private', not public.
2. Make sure that the WIndows advanced sharing options on the laptop has the settings set to turn on network discovery, file & printer sharing for the Private networks (I do the public too, and turn it off when I'm not on a private network), and for ALL networks, turn ON sharing for accessing files, set to use 128bit encryption, and turn OFF password protected sharing.
3. Insure that the Powerchurch shared drive from the 'server' has full read & write permissions to everyone.


1. Done (though it did it while on the churches internal network too)
2. Done
3. Confirmed.

No change. Access is still denied.

Yes, it's a shared drive that both machines use.

It did update on the next launch, but wouldn't reindex (which is my metric for if the program will post data). I brought it because I was already going there for midweek ministry and had to make sure the bookkeepers machine updated and was working still while I was on site to fix it rather than having to remote in. Plus if the machine worked I was going to leave it for the actual user of the machine.
AndyMBC
 
Posts: 9
Joined: Wed Sep 12, 2018 8:43 pm

Re: Netsetup115 access is denied after uninstalling

Postby NeilZ » Thu Sep 13, 2018 11:03 am

AndyMBC wrote:
NeilZ wrote:This is definitely a Windows sharing issue, and not a Powerchurch one.
I suggest the following;

1. Make sure that the laptop views the church network as 'Private', not public.
2. Make sure that the WIndows advanced sharing options on the laptop has the settings set to turn on network discovery, file & printer sharing for the Private networks (I do the public too, and turn it off when I'm not on a private network), and for ALL networks, turn ON sharing for accessing files, set to use 128bit encryption, and turn OFF password protected sharing.
3. Insure that the Powerchurch shared drive from the 'server' has full read & write permissions to everyone.


1. Done (though it did it while on the churches internal network too)
2. Done
3. Confirmed.

No change. Access is still denied.

Yes, it's a shared drive that both machines use.

It did update on the next launch, but wouldn't reindex (which is my metric for if the program will post data). I brought it because I was already going there for midweek ministry and had to make sure the bookkeepers machine updated and was working still while I was on site to fix it rather than having to remote in. Plus if the machine worked I was going to leave it for the actual user of the machine.


Normally, if it won't reindex its due to someone else being in the database, and the system will tell you that.

If you're sure everyone is signed out of the system, but the one machine, and it won't reindex. Then there's other issues.

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8905
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA

Re: Netsetup115 access is denied after uninstalling

Postby AndyMBC » Thu Sep 13, 2018 11:11 am

I'm pretty sure the other machine was closed at that point, but either way I still can't reinstall powerchurch now on that machine to even consider reindexing issues.
AndyMBC
 
Posts: 9
Joined: Wed Sep 12, 2018 8:43 pm

Re: Netsetup115 access is denied after uninstalling

Postby NeilZ » Thu Sep 13, 2018 11:19 am

AndyMBC wrote:I'm pretty sure the other machine was closed at that point, but either way I still can't reinstall powerchurch now on that machine to even consider reindexing issues.


Andy .. its a Windows permissions problem and/or firewall/antivirus issue. Not much we can do here other than advise you check the share permissions on the 'server', the setup on the laptop, and direct you to the knowledgebase article:

https://www.powerchurch.com/support/35/ ... work-drive

It uses a simple sharing procedure, nothing else.

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8905
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA

Re: Netsetup115 access is denied after uninstalling

Postby AndyMBC » Thu Sep 13, 2018 5:51 pm

So I'm running a mac os server, and if I use the share /Power Church/PCPLUS115/install/ which the login has full read/write permissions for this new computer returns access is denied.

If I use the full path /Drobo/Power Church/PCPLUS115/install/ it works fine.

The problem is this allows everyone with a server login to see my whole root directory basically on the Drobo.

The first path I posted works completely fine on another machine, using the same logins, so I don't understand why this one machine refuses to do the same. It didn't matter what login I used, the results were always the same, even using the root login.

The issue only seemed to have became one after I uninstalled via control panel. Does that not fully clear everything? I just tried that first install path on my machine over VPN and it worked fine.

I did just end up nuking the new machine and I'm just never gonna touch it.
AndyMBC
 
Posts: 9
Joined: Wed Sep 12, 2018 8:43 pm

Re: Netsetup115 access is denied after uninstalling

Postby NeilZ » Thu Sep 13, 2018 7:06 pm

AndyMBC wrote:So I'm running a mac os server, and if I use the share /Power Church/PCPLUS115/install/ which the login has full read/write permissions for this new computer returns access is denied.

If I use the full path /Drobo/Power Church/PCPLUS115/install/ it works fine.

The problem is this allows everyone with a server login to see my whole root directory basically on the Drobo.

The first path I posted works completely fine on another machine, using the same logins, so I don't understand why this one machine refuses to do the same. It didn't matter what login I used, the results were always the same, even using the root login.

The issue only seemed to have became one after I uninstalled via control panel. Does that not fully clear everything? I just tried that first install path on my machine over VPN and it worked fine.


How was it installed the first time? Is the share drive listed as a 'lettered' drive on the laptop? I've run powerchurch off a NAS drive running Linux without a problem, but is mapped on the Windows machine to a local drive letter.

is the powerchurch share mapped to a local drive letter?

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8905
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA

Re: Netsetup115 access is denied after uninstalling

Postby AndyMBC » Thu Sep 13, 2018 7:10 pm

NeilZ wrote:How was it installed the first time? Is the share drive listed as a 'lettered' drive on the laptop? I've run powerchurch off a NAS drive running Linux without a problem, but is mapped on the Windows machine to a local drive letter.

is the powerchurch share mapped to a local drive letter?


Yes, I have the drive mapped, navigated to the install directory and ran netsetup, eventually windows asked me for a share login which I provided, and it all worked fine. It was just after I installed via control panel that it wouldn't reinstall.
AndyMBC
 
Posts: 9
Joined: Wed Sep 12, 2018 8:43 pm

Re: Netsetup115 access is denied after uninstalling

Postby NeilZ » Thu Sep 13, 2018 7:15 pm

AndyMBC wrote:
NeilZ wrote:How was it installed the first time? Is the share drive listed as a 'lettered' drive on the laptop? I've run powerchurch off a NAS drive running Linux without a problem, but is mapped on the Windows machine to a local drive letter.

is the powerchurch share mapped to a local drive letter?


Yes, I have the drive mapped, navigated to the install directory and ran netsetup, eventually windows asked me for a share login which I provided, and it all worked fine. It was just after I installed via control panel that it wouldn't reinstall.


The problem is that Windows should NOT be asking you for a 'share login'. If you have the Powerchurch directory shared with full access to all (now in linux you would set the permissions to 777), and have Windows setup to NOT use password protection on the shares, you shouldn't be getting a request for a login.

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8905
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA

Re: Netsetup115 access is denied after uninstalling

Postby AndyMBC » Thu Sep 13, 2018 7:42 pm

Okay so that seems like what is causing the issue then. I launched netsetup and after it started it asked for a login. Then it gave me this error and refused to go further. Image

I guess I need to remove that login because now the "Access is Denied" error has returned.

The problem is I've removed the login from credentials manager but don't see anywhere else to remove it.

Also I did just go ahead and chmod the whole directory -R 777, just need to figure out where it's got a saved login.
AndyMBC
 
Posts: 9
Joined: Wed Sep 12, 2018 8:43 pm

Re: Netsetup115 access is denied after uninstalling

Postby AndyMBC » Thu Sep 13, 2018 9:45 pm

So I did yet another system reinstall, and this time I'm not putting any logins in, so they don't get saved.

I mounted the drive which of course required logging into the SMB server, which I figured was expected.

Upon running netsetup115.exe I first get UAC asking to confirm I want to install it then it asks me to "Enter Network Password". Which I am not doing. Like I said in the last post I did chmod that whole folder 777 as you mentioned.
AndyMBC
 
Posts: 9
Joined: Wed Sep 12, 2018 8:43 pm

Next