Not able to run reports

Got a question or comment about PowerChurch that doesn't belong anywhere else? Why not post it here!?

Not able to run reports

Postby gospeltab » Sun Nov 18, 2018 1:45 pm

Hi,

We are running powerchurch 12+. We recently had our computer crash. I installed Powerchurch on the new laptop and loaded all of our data and everything seemed to be going well until we tried to print reports. Now all we get is error messages.

The first window says: Program Error: Unknown member OVIEWER

The next window says: variable NNEWPAGE is not found

The next: Error: 1426
method: crystal2.NewObject
Line: 0
Message: OLE errorcode Ox80040154: class not registered

The next: Error: 1734
Method: run_report
Line: 79
Message: Property OVIEWER is not found

The next: Error: 1940
method: run_report
Line: 80
Message: Expression is not valid outside of WITH/ENDWITH

I don't have any idea how to fix this! If anyone can help I would really appreciate it!

Deanne
gospeltab
 
Posts: 66
Joined: Wed Feb 17, 2010 11:00 pm

Re: Not able to run reports

Postby NeilZ » Sun Nov 18, 2018 2:11 pm

gospeltab wrote:Hi,

We are running powerchurch 12+. We recently had our computer crash. I installed Powerchurch on the new laptop and loaded all of our data and everything seemed to be going well until we tried to print reports. Now all we get is error messages.

The first window says: Program Error: Unknown member OVIEWER

The next window says: variable NNEWPAGE is not found

The next: Error: 1426
method: crystal2.NewObject
Line: 0
Message: OLE errorcode Ox80040154: class not registered

The next: Error: 1734
Method: run_report
Line: 79
Message: Property OVIEWER is not found

The next: Error: 1940
method: run_report
Line: 80
Message: Expression is not valid outside of WITH/ENDWITH

I don't have any idea how to fix this! If anyone can help I would really appreciate it!

Deanne


Is this on Windows 10? When you did the install, did you apply the latest Maintenance Release?

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8904
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA

Re: Not able to run reports

Postby gospeltab » Sun Nov 18, 2018 2:16 pm

It was installed on Monday, Nov. 12. I did run the newest maintenance release. We are running Windows 10. And we have office 16.
gospeltab
 
Posts: 66
Joined: Wed Feb 17, 2010 11:00 pm

Re: Not able to run reports

Postby NeilZ » Sun Nov 18, 2018 2:47 pm

gospeltab wrote:It was installed on Monday, Nov. 12. I did run the newest maintenance release. We are running Windows 10. And we have office 16.


OK ..it should read 10/10/2018.

This is the first time I've seen this issue here on the forums, so it may be local to your computer.

I'm going to suggest that you call Powerchurch on Monday.

However, you may want to try this first:

1. Do a Powerchurch backup of your database.
2. Uninstall Powerchurch from the computer.
3. Reboot the computer.
4. Download the Maintenance Release from Powerchurch, before you reinstall the program.
5. Reinstall the program, do NOT allow the setup program to start Powerchurch.
6. Find the MR file that you downloaded and run it to update Powerchurch.
7. Start Powerchurch, its going to ask you if you are loading from a backup, select that and use the backup you made in step 1.
8. Try to run a report.

If you still have that issue, call Powerchurch direct.

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8904
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA