Printing Directory Problem

Postby centralchurch » Tue May 17, 2016 10:21 am

Very strange. I generate a directory of our members. I choose which categories I want to include. Of the few I choose, the main one would be "Active Member". When I print the directory, oddly, a handful of members (who are categorized as an 'active member'), are missing! Simply not on the report!!! So, I thought "do I have them in a different category?" ... no! Everything looks right in line. How does this happen and how can I fix it? Thanks in advance! :D
centralchurch
 
Posts: 6
Joined: Tue May 17, 2016 10:17 am

Re: Printing Directory Problem

Postby tborgal » Tue May 17, 2016 10:46 am

Make sure that the "Include in Membership Module Reports" option is checked on the families that do not show up on the report.

Tom
tborgal
 
Posts: 857
Joined: Thu Jun 03, 2004 3:55 pm
Location: New England Bible Church, Andover, MA

Re: Printing Directory Problem

Postby NeilZ » Tue May 17, 2016 1:14 pm

FWIW ... that's the first thing one should look at if families and/or people are not showing up in Membership Reports. Its located on the Family Mailing Record, which is the first thing you see if you maintain records using the Intergrated Data Entry function.

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8905
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA

Re: Printing Directory Problem

Postby centralchurch » Wed May 18, 2016 2:36 pm

tborgal wrote:Make sure that the "Include in Membership Module Reports" option is checked on the families that do not show up on the report.



Thank you for your reply. All families missing from my report did have the box checked as you suggested. Still they are missing.
Any other suggestions?
centralchurch
 
Posts: 6
Joined: Tue May 17, 2016 10:17 am

Re: Printing Directory Problem

Postby centralchurch » Wed May 18, 2016 2:39 pm

NeilZ wrote:FWIW ... that's the first thing one should look at if families and/or people are not showing up in Membership Reports. Its located on the Family Mailing Record, which is the first thing you see if you maintain records using the Intergrated Data Entry function.



I'm sorry, I don't know what "FWIW" means.
centralchurch
 
Posts: 6
Joined: Tue May 17, 2016 10:17 am

Re: Printing Directory Problem

Postby NeilZ » Wed May 18, 2016 3:05 pm

centralchurch wrote:
NeilZ wrote:FWIW ... that's the first thing one should look at if families and/or people are not showing up in Membership Reports. Its located on the Family Mailing Record, which is the first thing you see if you maintain records using the Intergrated Data Entry function.



I'm sorry, I don't know what "FWIW" means.


For What Its Worth ...

OK .. try this, I'm assuming that you're using PCPlus v11.x, and the directory you're trying to generate is the directory report listed under the Personal Profile Reports

1. First do a REINDEX of the database. This is found under the UTILITIES menu.
2. Try pulling up these members using the Selected Names, Addresses, Phones report under the Personal Profiles reports. Only select one personal profile status at a time. Does this reflect all the names it should? If so, then there may be a problem with the filters you're using for the directory.
If not, then there's another issue.

Let us know what happens.

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8905
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA

Re: Printing Directory Problem

Postby centralchurch » Wed May 18, 2016 3:56 pm

Thank you, and I apologize. I don't use initials of words as shorthand. I know some basics, but once the letters add up to 4 or more... I'm lost. HA! (I mean, LOL)

Yes, I do have PCPlus v11.x
I did a REINDEX. Chose "all" and got a warning that one or more could not be done - that perhaps another user was using the program in another location. Well, that can't be. I'm the only one that uses it. So, that was curious.

Next I went to "Personal Profiles Reports". The people that are missing in our directory - ARE indeed in this report.

I have noticed that you can print a "directory" from a variety of avenues. I'm wondering if this makes a difference.

I'm deleting the four families I'm having this trouble with, and re-entering them. Maybe that will help. This is strange.








For What Its Worth ...

OK .. try this, I'm assuming that you're using PCPlus v11.x, and the directory you're trying to generate is the directory report listed under the Personal Profile Reports

1. First do a REINDEX of the database. This is found under the UTILITIES menu.
2. Try pulling up these members using the Selected Names, Addresses, Phones report under the Personal Profiles reports. Only select one personal profile status at a time. Does this reflect all the names it should? If so, then there may be a problem with the filters you're using for the directory.
If not, then there's another issue.

Let us know what happens.[/quote]
centralchurch
 
Posts: 6
Joined: Tue May 17, 2016 10:17 am

Re: Printing Directory Problem

Postby centralchurch » Wed May 18, 2016 4:22 pm

I ended up removing the four families missing from the directory. And adding them again.
Now they are on the directory report.
I don't understand why this happened. But I'm glad it's fixed.

So, you can make a directory from the family mailing list (reports)
or also the personal profiles (reports).

Is there a difference between the two? Would I get two different results if I made one from each?

Thanks for your help
centralchurch
 
Posts: 6
Joined: Tue May 17, 2016 10:17 am

Re: Printing Directory Problem

Postby centralchurch » Wed May 18, 2016 4:36 pm

Now trying to figure out why a name is on my directory listing but I cannot find this person anywhere in the software. This has happened before. I delete a person but they still show up on reports. Frustrating.

Thanks for your help again. This forum is an awesome help.
centralchurch
 
Posts: 6
Joined: Tue May 17, 2016 10:17 am

Re: Printing Directory Problem

Postby NeilZ » Wed May 18, 2016 6:51 pm

centralchurch wrote:Now trying to figure out why a name is on my directory listing but I cannot find this person anywhere in the software. This has happened before. I delete a person but they still show up on reports. Frustrating.

Thanks for your help again. This forum is an awesome help.


It sounds like there is a problem with your database. What I would do is this:

1. Exit the program.
2. Reboot your computer.
3. Start the program, and immediately do a reindex.
4. If you still get an error from the reindex saying that someone has a locked file, then jot down the name of the file (if given) and let us know.

Neil Zampella

Using PC+ since 1999.
NeilZ
 
Posts: 8905
Joined: Wed Oct 08, 2003 12:20 am
Location: Connellsville, PA