PowerChurch Software Downloads

Maintenance Releases

Download the latest update for your PowerChurch Plus version. (More info)

PowerChurch Online/IDS Client

Download the IDS Client software to access PowerChurch Online. (More info)

Full Working Demo

Download the full-working demo installer, request a copy on CD, or access the PowerChurch Online demo.

Remote Helpdesk

PowerChurch Software Technical Support Remote Helpdesk client.

Check Reader Drivers

Device drivers and software necessary to run USB check readers. Newer versions of the USB check reader do not require any drivers. (More info)

Check Reader Update for PCPLUS10 on 64 bit Windows

The latest check reader drivers for 64 bit Windows versions are not recognized by PowerChurch Plus Version 10. Download and install this file on each workstation where you will be using the Check Reader. Newer versions of PowerChurch Plus were updated with these changes via Maintenance Release.

Updated Presort Files (Ver. 7 and higher)

This file contains the most up-to-date presort information available from the United States Postal Service. If you are using PowerChurch Plus 7 or above to assist with your presorting operations, you should download and install this revised data.

Updated DynaZip files (Ver. 8)

Some users have reported that when you verify a backup, a fatal error is generated and PowerChurch closes, and sometimes forces a restart of Windows. To correct this problem, you will need to download a newer copy of the DynaZip library files (DLLs).

FoxPro Library Files (Ver. 6.x)

Some users may experience a "divide by zero" error when using a Pentium II 350 MHZ or faster machine. This error is caused by a problem in Microsoft's FoxPro 2.6 Library Files, affecting PowerChurch Plus versions 6.1 and 6.2. If you are experiencing this problem, please download this patch.

Pocket PowerChurch v1.05 Update

This is an update to the latest build of version 1 of Pocket PowerChurch. Install this if you are receiving a "System Admin password is incorrect" error when syncing with version 9 or 10. DO NOT install this if you are using version 2.

Pocket PowerChurch v2.06 Update

This is an update to the latest build of version 2 of Pocket PowerChurch. Install this if you are receiving a "Class definition PCPLUS10.HELPER is not found" error when syncing with version 11. DO NOT install this if you are using version 1.